package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[#\s]*CI_ENVIRONMENT[=\s]+(?:[a-z]+)$`)
var str = `#CI_ENVIRONMENT=production
# CI_ENVIRONMENT=development
# CI_ENVIRONMENT = development
#CI_ENVIRONMENT = production`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}