const regex = /^[#\s]*CI_ENVIRONMENT[=\s]+(?:[a-z]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[#\\s]*CI_ENVIRONMENT[=\\s]+(?:[a-z]+)$', 'gm')
const str = `#CI_ENVIRONMENT=production
# CI_ENVIRONMENT=development
# CI_ENVIRONMENT = development
#CI_ENVIRONMENT = production`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}