// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[#\s]*CI_ENVIRONMENT[=\s]+(?:[a-z]+)$").unwrap();
let string = "#CI_ENVIRONMENT=production
# CI_ENVIRONMENT=development
# CI_ENVIRONMENT = development
#CI_ENVIRONMENT = production";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}