#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/(de|fr|en|it)/[^/\n]{2}(?:/[^/\n]+){2}$"
Local $sString = "Include:" & @CRLF & _
"" & @CRLF & _
"/de/ab/word-word/word1-and-something-else" & @CRLF & _
"/de/ab/word-word/word1-and-something-else?any_ting1=any.-thing2" & @CRLF & _
"" & @CRLF & _
"Exclude:" & @CRLF & _
"" & @CRLF & _
"/de/ab/word-word/word1-and-something-else/" & @CRLF & _
"/de/ab/word-word/word1-and-something-else/anything" & @CRLF & _
"/de/ab/word-word" & @CRLF & _
"/fr/moreThanTwoCHAR/anything" & @CRLF & _
"/de/ab/word-word/word1-and-something-else/anything"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")