import re
regex = re.compile(r"^/(de|fr|en|it)/[^/\n]{2}(?:/[^/\n]+){2}$", flags=re.MULTILINE)
test_str = ("Include:\n\n"
"/de/ab/word-word/word1-and-something-else\n"
"/de/ab/word-word/word1-and-something-else?any_ting1=any.-thing2\n\n"
"Exclude:\n\n"
"/de/ab/word-word/word1-and-something-else/\n"
"/de/ab/word-word/word1-and-something-else/anything\n"
"/de/ab/word-word\n"
"/fr/moreThanTwoCHAR/anything\n"
"/de/ab/word-word/word1-and-something-else/anything")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")