package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/(de|fr|en|it)/[^/\n]{2}(?:/[^/\n]+){2}$`)
var str = `Include:
/de/ab/word-word/word1-and-something-else
/de/ab/word-word/word1-and-something-else?any_ting1=any.-thing2
Exclude:
/de/ab/word-word/word1-and-something-else/
/de/ab/word-word/word1-and-something-else/anything
/de/ab/word-word
/fr/moreThanTwoCHAR/anything
/de/ab/word-word/word1-and-something-else/anything`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}