$re = '~^/(de|fr|en|it)/[^/\n]{2}(?:/[^/\n]+){2}$~m';
$str = 'Include:
/de/ab/word-word/word1-and-something-else
/de/ab/word-word/word1-and-something-else?any_ting1=any.-thing2
Exclude:
/de/ab/word-word/word1-and-something-else/
/de/ab/word-word/word1-and-something-else/anything
/de/ab/word-word
/fr/moreThanTwoCHAR/anything
/de/ab/word-word/word1-and-something-else/anything';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);