# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)\b(X\d{2})(?:(?!X\d{2}).)*["\s]([^"\s]+\.dun)+|(?:(?!X\d{2}).)*/$1\t\t$2\n/g;t' <<< "X12
Source =asdjkasjd
file=\"x/y1.dun\"
\"x/y2.dun\"
\"x/y3.dun\"
asds12
X22
p/q/xy.dun
asda=23
source =asdf
X44
1000
1001
file=\"abc.dun\""