import Foundation
let pattern = #"(?s)\b(X\d{2})(?:(?!X\d{2}).)*["\s]([^"\s]+\.dun)+|(?:(?!X\d{2}).)*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
X12
Source =asdjkasjd
file="x/y1.dun"
"x/y2.dun"
"x/y3.dun"
asds12
X22
p/q/xy.dun
asda=23
source =asdf
X44
1000
1001
file="abc.dun"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\t\t$2\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)