use strict;
my $str = 'X12
Source =asdjkasjd
file="x/y1.dun"
"x/y2.dun"
"x/y3.dun"
asds12
X22
p/q/xy.dun
asda=23
source =asdf
X44
1000
1001
file="abc.dun"';
my $regex = qr/(?s)\b(X\d{2})(?:(?!X\d{2}).)*["\s]([^"\s]+\.dun)+|(?:(?!X\d{2}).)*/p;
my $subst = '$1\\t\\t$2\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";