const regex = /(?s)\b(X\d{2})(?:(?!X\d{2}).)*["\s]([^"\s]+\.dun)+|(?:(?!X\d{2}).)*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)\\b(X\\d{2})(?:(?!X\\d{2}).)*["\\s]([^"\\s]+\\.dun)+|(?:(?!X\\d{2}).)*', 'g')
const str = `X12
Source =asdjkasjd
file="x/y1.dun"
"x/y2.dun"
"x/y3.dun"
asds12
X22
p/q/xy.dun
asda=23
source =asdf
X44
1000
1001
file="abc.dun"`;
const subst = `$1\t\t$2\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);