using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:Z\d+)(\w)";
string input = @"Z171PZ7AZ23PZ7819AZ78GZ1AZ99IZ34O";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}