const regex = /(?:Z\d+)(\w)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:Z\\d+)(\\w)', 'g')
const str = `Z171PZ7AZ23PZ7819AZ78GZ1AZ99IZ34O`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}