package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:Z\d+)(\w)`)
var str = `Z171PZ7AZ23PZ7819AZ78GZ1AZ99IZ34O`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}