package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:ktm(?:-e|-(?:[^e\W]|e[^d\W])\w*)*-)?abcd(?:-e|-(?:[^e\W]|e[^d\W])\w*)*$`)
var str = `abcd-st-ed-qrew
ktm-ewe-abcd-st-ed-qrew
abcd-st-wer-qrew-wabe
ktm-ewe-abcd-st-qrew-qrrt
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}