import re
regex = re.compile(r"^(?:ktm(?:-e|-(?:[^e\W]|e[^d\W])\w*)*-)?abcd(?:-e|-(?:[^e\W]|e[^d\W])\w*)*$", flags=re.MULTILINE)
test_str = ("abcd-st-ed-qrew\n"
"ktm-ewe-abcd-st-ed-qrew\n"
"abcd-st-wer-qrew-wabe\n"
"ktm-ewe-abcd-st-qrew-qrrt\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")