const regex = new RegExp('^(?:ktm(?:-e|-(?:[^e\\W]|e[^d\\W])\\w*)*-)?abcd(?:-e|-(?:[^e\\W]|e[^d\\W])\\w*)*$', 'gm')
const str = `abcd-st-ed-qrew
ktm-ewe-abcd-st-ed-qrew
abcd-st-wer-qrew-wabe
ktm-ewe-abcd-st-qrew-qrrt
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}