using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((http|https):\/\/)(([a-zA-Z0-9\\._-]+\.[A-z A-Z]{2,6})|([0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}))(:[0-9]{1,4})*(\/[a-zA-Z0-9\&%\_\\.\/\-\~]*)?";
string input = @"http://test.com/
https://127.0.0.1:125/test
http://test.mizzisoft.com/mizzisoft/er/ws/soap.php";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}