re = /((http|https):\/\/)(([a-zA-Z0-9\\._-]+\.[A-z A-Z]{2,6})|([0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}))(:[0-9]{1,4})*(\/[a-zA-Z0-9\&%\_\\.\/\-\~]*)?/m
str = 'http://test.com/
https://127.0.0.1:125/test
http://test.mizzisoft.com/mizzisoft/er/ws/soap.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end