import re
regex = re.compile(r"((http|https):\/\/)(([a-zA-Z0-9\\._-]+\.[A-z A-Z]{2,6})|([0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}))(:[0-9]{1,4})*(\/[a-zA-Z0-9\&%\_\\.\/\-\~]*)?", flags=re.MULTILINE)
test_str = ("http://test.com/\n"
"https://127.0.0.1:125/test\n"
"http://test.mizzisoft.com/mizzisoft/er/ws/soap.php")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")