$re = '/((http|https):\/\/)(([a-zA-Z0-9\\\\._-]+\.[A-z A-Z]{2,6})|([0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}))(:[0-9]{1,4})*(\/[a-zA-Z0-9\&%\_\\\\.\/\-\~]*)?/m';
$str = 'http://test.com/
https://127.0.0.1:125/test
http://test.mizzisoft.com/mizzisoft/er/ws/soap.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);