using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<div [^>]*class=""[^""]*(?:first-class|another-class)[^""]*""[^>]*>)";
string input = @"<div class=""first-class"">
<div class=""another-class"">";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}