re = /(<div [^>]*class="[^"]*(?:first-class|another-class)[^"]*"[^>]*>)/i
str = '<div class="first-class">
<div class="another-class">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end