package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?isU)(<div [^>]*class="[^"]*(?:first-class|another-class)[^"]*"[^>]*>)`)
var str = `<div class="first-class">
<div class="another-class">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}