$re = '#(<div [^>]*class="[^"]*(?:first-class|another-class)[^"]*"[^>]*>)#isU';
$str = '<div class="first-class">
<div class="another-class">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);