import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]{2}\\d\\s([A-Z]+\\s)+)|([A-Z]{3}\\s([A-Z]+\\s)+)";
final String string = "ABC D A F DE3 D CD A\n"
+ "AB3 D T B\n"
+ "AE1 A D BE1 A D C\n"
+ "AE1 A E F\n"
+ "ABC D A F DE3 D CD A\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}