$re = '/([A-Z]{2}\d\s([A-Z]+\s)+)|([A-Z]{3}\s([A-Z]+\s)+)/mi';
$str = 'ABC D A F DE3 D CD A
AB3 D T B
AE1 A D BE1 A D C
AE1 A E F
ABC D A F DE3 D CD A
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);