import re
regex = re.compile(r"([A-Z]{2}\d\s([A-Z]+\s)+)|([A-Z]{3}\s([A-Z]+\s)+)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("ABC D A F DE3 D CD A\n"
"AB3 D T B\n"
"AE1 A D BE1 A D C\n"
"AE1 A E F\n"
"ABC D A F DE3 D CD A\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")