re = /([A-Z]{2}\d\s([A-Z]+\s)+)|([A-Z]{3}\s([A-Z]+\s)+)/mi
str = 'ABC D A F DE3 D CD A
AB3 D T B
AE1 A D BE1 A D C
AE1 A E F
ABC D A F DE3 D CD A
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end