using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^You have(?!hour|mins)";
string input = @"You have left 4 hour or 240 mins left
are you have left 4 hour or 240 mins left
You have 10 bucks";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}