const regex = /^You have(?!hour|mins)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^You have(?!hour|mins)', 'gm')
const str = `You have left 4 hour or 240 mins left
are you have left 4 hour or 240 mins left
You have 10 bucks`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}