re = /^You have(?!hour|mins)/m
str = 'You have left 4 hour or 240 mins left
are you have left 4 hour or 240 mins left
You have 10 bucks'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end