$re = '/^You have(?!hour|mins)/m';
$str = 'You have left 4 hour or 240 mins left
are you have left 4 hour or 240 mins left
You have 10 bucks';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);