#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[([^]]+)\]"
Local $sString = "" & @CRLF & _
"select " & @CRLF & _
"1 as [test]" & @CRLF & _
"from [dbo].[weirdTable]"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)