re = /\[([^]]+)\]/m
str = '
select
1 as [test]
from [dbo].[weirdTable]'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result