$re = '/\[([^]]+)\]/m';
$str = '
select
1 as [test]
from [dbo].[weirdTable]';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;