package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)user\s+(?<User>\w+)`)
var str = `Mon Aug 06 2018 19:35:34 whostname sshd[4191]: Failed password for backup from 27.96.191.11 port 3558 ssh2
Mon Aug 06 2018 19:35:59 whostname sshd[5625]: Failed password for nobody from 27.96.191.11 port 1574 ssh2
Mon Aug 06 2018 19:36:07 whostname sshd[3840]: Failed password for invalid user uni from 27.96.191.11 port 4916 ssh2
Mon Aug 06 2018 19:36:26 whostname sshd[66863]: pam_unix(sshd:session): session opened for user michael by (uid=0)
Mon Aug 06 2018 19:36:26 whostname sshd[1573]: Failed password for invalid user harry from 27.96.191.11 port 1025 ssh2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}