import Foundation
let pattern = #"user\s+(?<User>\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Mon Aug 06 2018 19:35:34 whostname sshd[4191]: Failed password for backup from 27.96.191.11 port 3558 ssh2
Mon Aug 06 2018 19:35:59 whostname sshd[5625]: Failed password for nobody from 27.96.191.11 port 1574 ssh2
Mon Aug 06 2018 19:36:07 whostname sshd[3840]: Failed password for invalid user uni from 27.96.191.11 port 4916 ssh2
Mon Aug 06 2018 19:36:26 whostname sshd[66863]: pam_unix(sshd:session): session opened for user michael by (uid=0)
Mon Aug 06 2018 19:36:26 whostname sshd[1573]: Failed password for invalid user harry from 27.96.191.11 port 1025 ssh2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)