const regex = /user\s+(?<User>\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('user\\s+(?<User>\\w+)', 'gm')
const str = `Mon Aug 06 2018 19:35:34 whostname sshd[4191]: Failed password for backup from 27.96.191.11 port 3558 ssh2
Mon Aug 06 2018 19:35:59 whostname sshd[5625]: Failed password for nobody from 27.96.191.11 port 1574 ssh2
Mon Aug 06 2018 19:36:07 whostname sshd[3840]: Failed password for invalid user uni from 27.96.191.11 port 4916 ssh2
Mon Aug 06 2018 19:36:26 whostname sshd[66863]: pam_unix(sshd:session): session opened for user michael by (uid=0)
Mon Aug 06 2018 19:36:26 whostname sshd[1573]: Failed password for invalid user harry from 27.96.191.11 port 1025 ssh2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}