package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-zA-Z0-9]+?)=(.+?)($|[, ]+?)`)
var str = `aaaa=1111, bbb=222asdasd, ccc=33@as4@3, ddd=4$*(*#@$@$\n\n`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}