// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([a-zA-Z0-9]+?)=(.+?)($|[, ]+?)").unwrap();
let string = "aaaa=1111, bbb=222asdasd, ccc=33@as4@3, ddd=4$*(*#@$@$\\n\\n";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}