$re = '/([a-zA-Z0-9]+?)=(.+?)($|[, ]+?)/';
$str = 'aaaa=1111, bbb=222asdasd, ccc=33@as4@3, ddd=4$*(*#@$@$\\n\\n';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);