re = /([a-zA-Z0-9]+?)=(.+?)($|[, ]+?)/
str = 'aaaa=1111, bbb=222asdasd, ccc=33@as4@3, ddd=4$*(*#@$@$\\n\\n'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end