package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^)(?:tomcat|vizql|hs_err|tdeserver64|tabprotosrv|nativeapi)(?:.*)(?:\.log|\.txt)$`)
var str = `tabprotosrv_backgrounder_0-0.txt
tomcat.log`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}