re = /(?:^)(?:tomcat|vizql|hs_err|tdeserver64|tabprotosrv|nativeapi)(?:.*)(?:\.log|\.txt)$/m
str = 'tabprotosrv_backgrounder_0-0.txt
tomcat.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end