use strict;
my $str = 'personal-trainers/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0
http://localhost:8080/personal-trainers/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0
http://localhost:8080/personal-trainers/pagina/2/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0';
my $regex = qr/(personal-trainers|fysiotherapeuten)(\/pagina\/([0-9]+))?\/?(\?([a-zA-Z0-9.-=&]+))?\/?/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";