// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(personal-trainers|fysiotherapeuten)(\/pagina\/([0-9]+))?\/?(\?([a-zA-Z0-9.-=&]+))?\/?").unwrap();
let string = "personal-trainers/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0
http://localhost:8080/personal-trainers/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0
http://localhost:8080/personal-trainers/pagina/2/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}