re = /(personal-trainers|fysiotherapeuten)(\/pagina\/([0-9]+))?\/?(\?([a-zA-Z0-9.-=&]+))?\/?/m
str = 'personal-trainers/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0
http://localhost:8080/personal-trainers/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0
http://localhost:8080/personal-trainers/pagina/2/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result