#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*"
Local $sString = "Name: Oski, Year: ???, SID: 123456789" & @CRLF & _
"Name: Leon, Year: Senior, SID: 382049283 (this is just something random)" & @CRLF & _
"Name: Peter, Year: Junior, SID: 329840020 (also something random)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")