// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*").unwrap();
let string = "Name: Oski, Year: ???, SID: 123456789
Name: Leon, Year: Senior, SID: 382049283 (this is just something random)
Name: Peter, Year: Junior, SID: 329840020 (also something random)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}